Firefox 3 (Release Candidate 1) and Hit-a-Hint

by Ted Jardine Monday, June 02, 2008 10:39 PM

UPDATE: Installer (link below) updated to work with Firefox 3.1

UPDATE: LoL is a new and improved fork of HaH

Peter let us know this morning that several indispensable Firefox add-ons are now compatible with Firefox 3 RC1:

So off I went as that was the only reason I was holding off. Installed without problems and I love it. In just using it for a very short time (less than an hour):

  1. Sites load fast. And memory usage is much improved (right now with a couple tabs open I'm looking at 70MB whereas before it was regularly several hundred megs).
  2. Firefox itself loads very fast. Although some of this could be attributed to some add-ons that have been disabled now, it nevertheless is so much faster that even if the slug has not quite become a steed, it’s still awfully studly.
  3. The new functionality in the location bar is great.
  4. The add-ons dialogue is much improved. It's a small thing, but the reduced number of clicks to get an add-on installed makes a whole lot more sense than before.

And that's just what I've noticed right off the bat.

However, at first I thought Hit-a-Hint (a great add-on that makes it easy to do fast mouseless browsing) would be joining ColorZilla, Personal Menu, and a few others on the "not yet ready for 3" list, but searching the comments, sukhoy-isu mentions you can do a simple xpi installer change to get it going. Now how do you do that you may ask? Well, rather easily:

  1. Get the hah_0_9_1.xpi installer from, or rather, because the link is not available from within Firefox 3, go to
  2. The xpi file is a compressed archive, so use something like 7-zip to open it up and extract the install.rdf file.
  3. Open the install.rdf file in your favorite text editor and modify the maxVersion value to 3.0 and save.
  4. Plunk the install.rdf file back into the hah_0_9_1.xpi compressed archive.
  5. Go to File -> Open File and locate your hah_0_9_1.xpi file and go through the resulting add-on installer process.
  6. Voila! Start hitting your hints! 

Or, go the easy way and download the one I put together. Just change the extension from .zip to .xpi before opening it with Firefox.

Of course, your mileage may vary. Anything bad that ensues, don't blame me. It's not my fault. As always, it's Peter's.

UPDATE: installer updated to work with Firefox 3.1

Tags: Firefox | tools

blog comments powered by Disqus

Month List