IIS and Skype: Web site won't start

by Ted Jardine Wednesday, May 02, 2007 5:42 PM

Oh mercy me. What to do when you attempt to start a web site in IIS and you're confronted with something along the lines of "There was an error while performing this operation. The process cannot access the file"? Of course, after wasting 20 minutes googling (thinking that it could be any number of things I've got going on my machine, chiefly that I'm running Vista) and discovering kb articles like http://support.microsoft.com/kb/890015 I figured out that yes, something is using port 80, but what? Along comes http://forums.iis.net/thread/1636766.aspx to the rescue: fire up Windows Task Manager and see what's running under the listed process ID, but first, ARGH! Only now do I remember that this same thing happened over a year ago on my XP machine: good ol' Skype had snagged port 80 before IIS could get to it leading to the same useless error message. The pain.

Sometimes Skype gets to port 80 first, and sometimes IIS. So sometimes all is well, and other times...not. Make sure that all is well all the time by doing the following: Open up Skype -> Tools -> Options -> Connection and uncheck "Use port 80 and 443 as alternatives for incoming connections." Of course, you might need to have this checked due to a corporate firewall or something, but.... For those wondering, to find out whether port 80 really is in use, open a command window and type in "netstat -ano" without the quotes. If it's listed it's being used. Wouldn't it be nice if the error message said "port 80 is in use so this web site cannot be started"?

Tags:

blog comments powered by Disqus

Month List